import Foundation
let pattern = #"<!--\s*(.*)\s*-->"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<!-- Comment 1 -->
<!-- Comment 2 -->
<!-- Integer arcu tincidunt lorem odio dolor cum sit nec, risus, odio, placerat magna porta habitasse enim et sit. Dapibus enim! Cum! Et? Arcu, natoque mattis, lorem. Placerat, nec -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)