import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!(?:[+-]?\\d*\\.?\\d+(?:e[+-]?\\d+)?|log|sin|cos)\\b)\\w+\\b";
final String string = "(var1 * 1.3e4 + abc)/log(blabla+2E3)\n"
+ "1.2E+23";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}