$re = '/\b(?!(?:[+-]?\d*\.?\d+(?:e[+-]?\d+)?|log|sin|cos)\b)\w+\b/i';
$str = '(var1 * 1.3e4 + abc)/log(blabla+2E3)
1.2E+23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);