re = /\b(?!(?:[+-]?\d*\.?\d+(?:e[+-]?\d+)?|log|sin|cos)\b)\w+\b/i
str = '(var1 * 1.3e4 + abc)/log(blabla+2E3)
1.2E+23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end