#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\[[\d\D]*?]]"
Local $sString = "blablablabla[["<strong>LA DEFENSE 4 TEMPS ( La Rotonde )</strong><br />Centre commercial LES 4 TEMPS"," & @CRLF & _
" 48.89141725," & @CRLF & _
" 2.23478235," & @CRLF & _
" "4T"]," & @CRLF & _
" ["<strong>ANGERS</strong><br />Centre commercial GEANT"," & @CRLF & _
" 48.89141725," & @CRLF & _
" 2.23478235," & @CRLF & _
" "4T"]]blablablabla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")