using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[[\d\D]*?]]";
string input = @"blablablabla[[""<strong>LA DEFENSE 4 TEMPS ( La Rotonde )</strong><br />Centre commercial LES 4 TEMPS"",
48.89141725,
2.23478235,
""4T""],
[""<strong>ANGERS</strong><br />Centre commercial GEANT"",
48.89141725,
2.23478235,
""4T""]]blablablabla";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}