const regex = /\[\[[\d\D]*?]]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[[\\d\\D]*?]]', 'g')
const str = `blablablabla[["<strong>LA DEFENSE 4 TEMPS ( La Rotonde )</strong><br />Centre commercial LES 4 TEMPS",
48.89141725,
2.23478235,
"4T"],
["<strong>ANGERS</strong><br />Centre commercial GEANT",
48.89141725,
2.23478235,
"4T"]]blablablabla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}