// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\[[\d\D]*?]]").unwrap();
let string = "blablablabla[[\"<strong>LA DEFENSE 4 TEMPS ( La Rotonde )</strong><br />Centre commercial LES 4 TEMPS\",
48.89141725,
2.23478235,
\"4T\"],
[\"<strong>ANGERS</strong><br />Centre commercial GEANT\",
48.89141725,
2.23478235,
\"4T\"]]blablablabla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}