using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"InstrumentID\s+\:([a-z]{2}\d+)\n";
string input = @"MessageID :1079247881
InstrumentID :DS5431460001
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}