re = /InstrumentID\s+\:([a-z]{2}\d+)\n/i
str = 'MessageID :1079247881
InstrumentID :DS5431460001
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end