const regex = /InstrumentID\s+\:([a-z]{2}\d+)\n/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('InstrumentID\\s+\\:([a-z]{2}\\d+)\\n', 'i')
const str = `MessageID :1079247881
InstrumentID :DS5431460001
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}