$re = '/InstrumentID\s+\:([a-z]{2}\d+)\n/i';
$str = 'MessageID :1079247881
InstrumentID :DS5431460001
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);