using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}(?!([^<]*>)|(((?!<a).)*<\/a>))";
string input = @"<div id=""departments"">
<ul>
<li>Department 1 - 8141113900</li>
<li>Department 2 - pavan 8141119300</li>
<li>Department 3 - (555) 123-6789</li>
</ul>
</div>
<input type='text' value='(555) 123-6789' />
(555) 123-6789 <a href=''>(555) 123-6789</a><a href='(555) 123-6789'>(555) 123-6789</a>
<li>Department 1 -<b> (555) 123-1234</b></li>
<li>Department 2 - (555) 123-4321</li>
<li>Department 3 - (555) 123-6789</li>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}