const regex = /((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}(?!([^<]*>)|(((?!<a).)*<\/a>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\(\\d{3}\\) ?)|(\\d{3}-))?\\d{3}-\\d{4}(?!([^<]*>)|(((?!<a).)*<\\\/a>))', 'g')
const str = `<div id="departments">
<ul>
<li>Department 1 - 8141113900</li>
<li>Department 2 - pavan 8141119300</li>
<li>Department 3 - (555) 123-6789</li>
</ul>
</div>
<input type='text' value='(555) 123-6789' />
(555) 123-6789 <a href=''>(555) 123-6789</a><a href='(555) 123-6789'>(555) 123-6789</a>
<li>Department 1 -<b> (555) 123-1234</b></li>
<li>Department 2 - (555) 123-4321</li>
<li>Department 3 - (555) 123-6789</li>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}