import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\(\\d{3}\\) ?)|(\\d{3}-))?\\d{3}-\\d{4}(?!([^<]*>)|(((?!<a).)*<\\/a>))";
final String string = "<div id=\"departments\">\n"
+ " <ul>\n"
+ " <li>Department 1 - 8141113900</li>\n"
+ " <li>Department 2 - pavan 8141119300</li>\n"
+ " <li>Department 3 - (555) 123-6789</li>\n"
+ " </ul>\n"
+ "</div>\n"
+ "<input type='text' value='(555) 123-6789' />\n"
+ "(555) 123-6789 <a href=''>(555) 123-6789</a><a href='(555) 123-6789'>(555) 123-6789</a>\n"
+ "<li>Department 1 -<b> (555) 123-1234</b></li>\n"
+ "<li>Department 2 - (555) 123-4321</li>\n"
+ "<li>Department 3 - (555) 123-6789</li>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}