import Foundation
let pattern = #"((\(\d{3}\) ?)|(\d{3}-))?\d{3}-\d{4}(?!([^<]*>)|(((?!<a).)*<\/a>))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div id="departments">
<ul>
<li>Department 1 - 8141113900</li>
<li>Department 2 - pavan 8141119300</li>
<li>Department 3 - (555) 123-6789</li>
</ul>
</div>
<input type='text' value='(555) 123-6789' />
(555) 123-6789 <a href=''>(555) 123-6789</a><a href='(555) 123-6789'>(555) 123-6789</a>
<li>Department 1 -<b> (555) 123-1234</b></li>
<li>Department 2 - (555) 123-4321</li>
<li>Department 3 - (555) 123-6789</li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)