#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:[A-Za-z0-9_][A-Za-z0-9_\-]*(?:\.[A-Za-z0-9_\-]+)*\/)+$"
Local $sString = "dir" & @CRLF & _
"dir/" & @CRLF & _
"dir//" & @CRLF & _
"dir./" & @CRLF & _
"-dir/" & @CRLF & _
".dir/" & @CRLF & _
"_dir/" & @CRLF & _
"__dir/" & @CRLF & _
"_-dir/" & @CRLF & _
"_.dir/" & @CRLF & _
"dir.name/" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ.abcdefghijklmnopqrstuvwxyz.0123456789_-/" & @CRLF & _
"dir/dir/filename" & @CRLF & _
"dir/dir/filename.ext" & @CRLF & _
"" & @CRLF & _
"// values currently used in wjec.services.properties:" & @CRLF & _
"dev.est.edientries.archive" & @CRLF & _
"dev-est-reports" & @CRLF & _
"dev-est-csv-import" & @CRLF & _
"dev-est-csv-import-archive" & @CRLF & _
"// alternatives:" & @CRLF & _
"dev.est.edientries.archive/" & @CRLF & _
"dev-est-reports/" & @CRLF & _
"dev-est-csv-import/" & @CRLF & _
"dev-est-csv-import-archive/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")