# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[A-Za-z0-9_][A-Za-z0-9_\-]*(?:\.[A-Za-z0-9_\-]+)*\/)+$"
test_str = ("dir\n"
"dir/\n"
"dir//\n"
"dir./\n"
"-dir/\n"
".dir/\n"
"_dir/\n"
"__dir/\n"
"_-dir/\n"
"_.dir/\n"
"dir.name/\n"
"ABCDEFGHIJKLMNOPQRSTUVWXYZ.abcdefghijklmnopqrstuvwxyz.0123456789_-/\n"
"dir/dir/filename\n"
"dir/dir/filename.ext\n\n"
"// values currently used in wjec.services.properties:\n"
"dev.est.edientries.archive\n"
"dev-est-reports\n"
"dev-est-csv-import\n"
"dev-est-csv-import-archive\n"
"// alternatives:\n"
"dev.est.edientries.archive/\n"
"dev-est-reports/\n"
"dev-est-csv-import/\n"
"dev-est-csv-import-archive/")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.