use strict;
my $str = 'dir
dir/
dir//
dir./
-dir/
.dir/
_dir/
__dir/
_-dir/
_.dir/
dir.name/
ABCDEFGHIJKLMNOPQRSTUVWXYZ.abcdefghijklmnopqrstuvwxyz.0123456789_-/
dir/dir/filename
dir/dir/filename.ext
// values currently used in wjec.services.properties:
dev.est.edientries.archive
dev-est-reports
dev-est-csv-import
dev-est-csv-import-archive
// alternatives:
dev.est.edientries.archive/
dev-est-reports/
dev-est-csv-import/
dev-est-csv-import-archive/';
my $regex = qr/^(?:[A-Za-z0-9_][A-Za-z0-9_\-]*(?:\.[A-Za-z0-9_\-]+)*\/)+$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}