# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a class=.*?href=".*?([^\\/]+)\.txt">.*?<\\/a>/<ac:link><ri:page ri:content-title="\1" \\/><\\/ac:link>/;t' <<< "<a class=\"xref\" href=\"../Test_Topic_1/Test_Topic_1.txt\">Test Topic 1</a>"