import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a class=.*?href=\".*?([^\\/]+)\\.txt\">.*?<\\/a>";
final String string = "<a class=\"xref\" href=\"../Test_Topic_1/Test_Topic_1.txt\">Test Topic 1</a>";
final String subst = "<ac:link><ri:page ri:content-title=\"\\1\" \\/><\\/ac:link>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}