$re = '/<a class=.*?href=".*?([^\/]+)\.txt">.*?<\/a>/';
$str = '<a class="xref" href="../Test_Topic_1/Test_Topic_1.txt">Test Topic 1</a>';
$subst = "<ac:link><ri:page ri:content-title=\"\1\" \/><\/ac:link>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;