// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a class=.*?href=".*?([^\/]+)\.txt">.*?<\/a>"#).unwrap();
let string = "<a class=\"xref\" href=\"../Test_Topic_1/Test_Topic_1.txt\">Test Topic 1</a>";
let substitution = "<ac:link><ri:page ri:content-title=\"\\1\" \\/><\\/ac:link>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}