import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "updi\\(event,'(.*)[ ](.*)[ ](.*)[ ]\\((.*)\\)<br>Distances: (.*nm)\\/(.*nm)<br><b>Wind:<\\/b>[ ](.*°)[ ](.*)[ ]\\(<b>TWA[ ](.*°)<\\/b>\\)<br><b>Heading:<\\/b>[ ](.*;)<b>Sail:<\\/b>[ ](.*)<br><b>Boat[ ]Speed:<\\/b>[ ](.*\\Wkts)','220px'\\)";
final String string = "updi(event,'2017-07-24 11:20 CEST (T+ 0:10)<br>Distances: 3.5nm/2751.0nm<br><b>Wind:</b> 197° 14.7 kt (<b>TWA 120°</b>)<br><b>Heading:</b> 77°<b>Sail:</b> Spi<br><b>Boat Speed:</b> 20.81 kts','220px')";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}