import re
regex = re.compile(r"updi\(event,'(.*)[ ](.*)[ ](.*)[ ]\((.*)\)<br>Distances: (.*nm)\/(.*nm)<br><b>Wind:<\/b>[ ](.*°)[ ](.*)[ ]\(<b>TWA[ ](.*°)<\/b>\)<br><b>Heading:<\/b>[ ](.*;)<b>Sail:<\/b>[ ](.*)<br><b>Boat[ ]Speed:<\/b>[ ](.*\Wkts)','220px'\)", flags=re.IGNORECASE)
test_str = "updi(event,'2017-07-24 11:20 CEST (T+ 0:10)<br>Distances: 3.5nm/2751.0nm<br><b>Wind:</b> 197° 14.7 kt (<b>TWA 120°</b>)<br><b>Heading:</b> 77°<b>Sail:</b> Spi<br><b>Boat Speed:</b> 20.81 kts','220px')"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")