const regex = /updi\(event,'(.*)[ ](.*)[ ](.*)[ ]\((.*)\)<br>Distances: (.*nm)\/(.*nm)<br><b>Wind:<\/b>[ ](.*°)[ ](.*)[ ]\(<b>TWA[ ](.*°)<\/b>\)<br><b>Heading:<\/b>[ ](.*;)<b>Sail:<\/b>[ ](.*)<br><b>Boat[ ]Speed:<\/b>[ ](.*\Wkts)','220px'\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('updi\\(event,\'(.*)[ ](.*)[ ](.*)[ ]\\((.*)\\)<br>Distances: (.*nm)\\\/(.*nm)<br><b>Wind:<\\\/b>[ ](.*°)[ ](.*)[ ]\\(<b>TWA[ ](.*°)<\\\/b>\\)<br><b>Heading:<\\\/b>[ ](.*;)<b>Sail:<\\\/b>[ ](.*)<br><b>Boat[ ]Speed:<\\\/b>[ ](.*\\Wkts)\',\'220px\'\\)', 'gi')
const str = `updi(event,'2017-07-24 11:20 CEST (T+ 0:10)<br>Distances: 3.5nm/2751.0nm<br><b>Wind:</b> 197° 14.7 kt (<b>TWA 120°</b>)<br><b>Heading:</b> 77°<b>Sail:</b> Spi<br><b>Boat Speed:</b> 20.81 kts','220px')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}