re = /updi\(event,'(.*)[ ](.*)[ ](.*)[ ]\((.*)\)<br>Distances: (.*nm)\/(.*nm)<br><b>Wind:<\/b>[ ](.*°)[ ](.*)[ ]\(<b>TWA[ ](.*°)<\/b>\)<br><b>Heading:<\/b>[ ](.*;)<b>Sail:<\/b>[ ](.*)<br><b>Boat[ ]Speed:<\/b>[ ](.*\Wkts)','220px'\)/i
str = 'updi(event,\'2017-07-24 11:20 CEST (T+ 0:10)<br>Distances: 3.5nm/2751.0nm<br><b>Wind:</b> 197° 14.7 kt (<b>TWA 120°</b>)<br><b>Heading:</b> 77°<b>Sail:</b> Spi<br><b>Boat Speed:</b> 20.81 kts\',\'220px\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end