#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/swaggerui\/PetStore\/index\.html\?urls\.primaryName=(?i)(?!.*Developer).*"
Local $sString = "/swaggerui/PetStore/index.html?urls.primaryName=V1-Private" & @CRLF & _
"/swaggerui/PetStore/index.html?urls.primaryName=V1-Internal" & @CRLF & _
"/swaggerui/PetStore/index.html?urls.primaryName=V1-Developer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")