$re = '/\/swaggerui\/PetStore\/index\.html\?urls\.primaryName=(?i)(?!.*Developer).*/m';
$str = '/swaggerui/PetStore/index.html?urls.primaryName=V1-Private
/swaggerui/PetStore/index.html?urls.primaryName=V1-Internal
/swaggerui/PetStore/index.html?urls.primaryName=V1-Developer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);