re = /\/swaggerui\/PetStore\/index\.html\?urls\.primaryName=(?i)(?!.*Developer).*/m
str = '/swaggerui/PetStore/index.html?urls.primaryName=V1-Private
/swaggerui/PetStore/index.html?urls.primaryName=V1-Internal
/swaggerui/PetStore/index.html?urls.primaryName=V1-Developer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end