const regex = /\/swaggerui\/PetStore\/index\.html\?urls\.primaryName=(?i)(?!.*Developer).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/swaggerui\\\/PetStore\\\/index\\.html\\?urls\\.primaryName=(?i)(?!.*Developer).*', 'gm')
const str = `/swaggerui/PetStore/index.html?urls.primaryName=V1-Private
/swaggerui/PetStore/index.html?urls.primaryName=V1-Internal
/swaggerui/PetStore/index.html?urls.primaryName=V1-Developer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}