using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( # Group 1
\( # Opening bracket
( # Group 2
(?: # Non-capturing group
[^()] # Match anything except opening or closing parentheses
| # Or
(?1) # Repeat Group 1
)* # Repeat the non-capturing group zero or more times
) # End of group 2
\) # Closing bracket
)";
string input = @"(user email ends with ""@email.com"" and user name is ""John"") or ((user email ends with ""@domain.com"" and user name is ""Bob"") or (user id is 5))";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}