package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`( # Group 1
\( # Opening bracket
( # Group 2
(?: # Non-capturing group
[^()] # Match anything except opening or closing parentheses
| # Or
(?1) # Repeat Group 1
)* # Repeat the non-capturing group zero or more times
) # End of group 2
\) # Closing bracket
)`)
var str = `(user email ends with "@email.com" and user name is "John") or ((user email ends with "@domain.com" and user name is "Bob") or (user id is 5))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}