import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( # Group 1\n"
+ " \\( # Opening bracket\n"
+ " ( # Group 2\n"
+ " (?: # Non-capturing group\n"
+ " [^()] # Match anything except opening or closing parentheses\n"
+ " | # Or\n"
+ " (?1) # Repeat Group 1\n"
+ " )* # Repeat the non-capturing group zero or more times\n"
+ " ) # End of group 2\n"
+ " \\) # Closing bracket\n"
+ ")";
final String string = "(user email ends with \"@email.com\" and user name is \"John\") or ((user email ends with \"@domain.com\" and user name is \"Bob\") or (user id is 5))";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}