import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<A>\\d+).*?(?<B>(\\+|-)?\\d+(\\.\\d)?)?\\s*(?<C>(\\+|-)\\d+(\\.\\d)?)$";
final String string = "100 4 2 12 3 +200 -100\n"
+ "100 4 2 12 3 -100\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}