import re
regex = re.compile(r"(?<A>\d+).*?(?<B>(\+|-)?\d+(\.\d)?)?\s*(?<C>(\+|-)\d+(\.\d)?)$", flags=re.MULTILINE)
test_str = ("100 4 2 12 3 +200 -100\n"
"100 4 2 12 3 -100\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")