$re = '/(?<A>\d+).*?(?<B>(\+|-)?\d+(\.\d)?)?\s*(?<C>(\+|-)\d+(\.\d)?)$/m';
$str = '100 4 2 12 3 +200 -100
100 4 2 12 3 -100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);