re = /(?<A>\d+).*?(?<B>(\+|-)?\d+(\.\d)?)?\s*(?<C>(\+|-)\d+(\.\d)?)$/m
str = '100 4 2 12 3 +200 -100
100 4 2 12 3 -100
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end