using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^:]|\s+)(\/\/.*)";
string input = @"function(){
//comment
var i = 0; // assignment
http://shittyundetectedurl.com
} // comment";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}