$re = '/(^|[^:]|\s+)(\/\/.*)/';
$str = 'function(){
//comment
var i = 0; // assignment
http://shittyundetectedurl.com
} // comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);