re = /(^|[^:]|\s+)(\/\/.*)/
str = 'function(){
//comment
var i = 0; // assignment
http://shittyundetectedurl.com
} // comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end