const regex = new RegExp('\\s(?=\\d+(?!\\S))', 'gm')
const str = `Dual 425mm AutoCannon 25`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);