use strict;
my $str = 'Dual 425mm AutoCannon 25';
my $regex = qr/\s(?=\d+(?!\S))/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";