import re
regex = re.compile(r"\s(?=\d+(?!\S))", flags=re.MULTILINE)
test_str = "Dual 425mm AutoCannon 25"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)