re = /\s(?=\d+(?!\S))/m
str = 'Dual 425mm AutoCannon 25'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result