using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(.?[^\.]*)\.(.?[^\/]*)\/(.*)";
string substitution = @"\1|||\2|||\3";
string input = @"https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip
https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}