import Foundation
let pattern = #"https:\/\/(.?[^\.]*)\.(.?[^\/]*)\/(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip
https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1|||\2|||\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)