use strict;
my $str = 'https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip
https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip
https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz';
my $regex = qr/https:\/\/(.?[^\.]*)\.(.?[^\/]*)\/(.*)/mp;
my $subst = '\\1|||\\2|||\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";