import re
regex = re.compile(r"https:\/\/(.?[^\.]*)\.(.?[^\/]*)\/(.*)", flags=re.MULTILINE)
test_str = ("https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/JGE_Template_20201022.gdb.zip\n"
"https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Cu_Geology/pCu_Geology.gdb.zip\n"
"https://jge-catalog-lake.s3.amazonaws.com/Approved_Data/Pet_Reservoir/JGE_Template_20201026.gdb.zip\n"
"https://jge-data-platform-primary-automation-prod.s3.amazonaws.com/DKU_TSHIRTS/orders_copy/out-s0.csv.gz")
subst = "\\1|||\\2|||\\3"
result = regex.sub(subst, test_str)
if result:
print(result)