#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\[|\G(?!^))[^]\s]*\K\s+"
Local $sString = "[Word1 Word2 Word3] word 4 word5 [ word6]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)